Skip over navigation
RSS

OroCommerce Blog

At Oro, we always look to keep up with the latest technologies to meet and exceed customer expectations. We also strive to keep the Community up to date with all major changes, so today we’re informing our users on the Oro products upgrade to the recent PHP security release.

Why You Need to Upgrade

Since PHP recently announced the availability of new security releases, all PHP users are highly recommended to upgrade the existing PHP installations. These releases contain many critical bug fixes required to bolster security.

The PHP versions to be upgraded include PHP 7.1 (all versions prior to 7.1.17, click here for the complete list of fixes), PHP 7.0 (all versions prior to 7.0.30, see the list of fixes for more details), and PHP 5.0 (all versions prior to 5.6.36, fixes).

How Oro Customers Will Upgrade to Newer PHP Versions

All recent versions of OroPlatform, OroCRM, and OroCommerce starting from 2.0 have been carefully tested for compatibility with the above-mentioned PHP versions. The inspection showed there were no vulnerabilities within the Oro products associated with the PHP bug fixes. Upgrading to a newer PHP version excludes any issues related to backward compatibility.

For Oro users, we suggest the following PHP upgrade scenarios:

  • We recommend all on-premise Oro customers to upgrade their production environments to PHP versions 7.1.17, 7.0.30 or 5.6.36 using PHP official download links.
  • OroCloud customers will have their production environments upgraded to the PHP versions 7.1.17, 7.0.30, and 5.6.36 by our team.

Stay tuned for further product news and updates we’ll be sharing with our Oro Community anytime soon.

Back to top

You will be redirected to [title]. Would you like to continue?

Yes No