Covering OroCRM topics, including community updates and company announcements.  Subscribe

Forums OroCRM OroCRM – Installation/Technical Issues or Problems Error updating and installing

This topic contains 0 replies, has 1 voice, and was last updated by  zebrahosting 2 years, 6 months ago.

  • Creator
  • #55460


    Just managed to install a working OROCRM which seems to run ok and connects to my Magento also fine.
    But when I want to run the update or install a package I get this warning:

    × The command “”/usr/bin/php” “/home/TAO/web/” cache:clear –no-warmup –env=prod” failed. Exit Code: 255(Unknown error) Output: ================ Error Output: ================ PHP Fatal error: Uncaught exception ‘Doctrine\DBAL\Driver\Mysqli\MysqliException’ with message ‘You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘:jobId, :name, :createdAt, :value)’ at line 1′ in /home/TAO/web/ Stack trace: #0 /home/TAO/web/ Doctrine\DBAL\Driver\Mysqli\MysqliStatement->__construct(Object(mysqli), ‘INSERT INTO jms…’) #1 /home/TAO/web/ Doctrine\DBAL\Driver\Mysqli\MysqliConnection->prepare(‘INSERT INTO jms…’) #2 /home/TAO/web/ Doctrine\DBAL\Statement->__construct(‘INSERT in /home/TAO/web/ on line 90

    I see that it is calling /usr/bin/php which should not be necessary (my cron also runs without).
    If I run the command in the console without the first part it opens a > prompt.

    Then I tried to run the update commands from the console:
    composer update (ends fine)

    app/console oro:platform:update ended in drama:

    PHP Fatal error: Uncaught exception ‘Symfony\Component\DependencyInjection\Exception\ParameterNotFoundException’ with message ‘The service “oro_wamp.publisher” has a dependency on a non-existent parameter “websocket_host”.’ in /home/TAO/web/
    Stack trace:
    #0 /home/TAO/web/ Symfony\Component\DependencyInjection\ParameterBag\ParameterBag->get(‘websocket_host’)
    #1 /home/TAO/web/ Symfony\Component\DependencyInjection\ParameterBag\ParameterBag->resolveString(‘%websocket_host…’, Array)
    #2 /home/TAO/web/ in /home/TAO/web/ on line 108

    The CRM is not working anymore. Blank page only.
    Not sure how to go from here.

    Suggestions welcome.

    MySQL version: 5.5.44-0ubuntu0.14.04.1 – (Ubuntu)
    Apache/2.4.7 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.0.1f

You must be logged in to reply to this topic.