ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

Forums OroCRM OroCRM – How do I? Questions impossible send email on change user password

This topic contains 11 replies, has 2 voices, and was last updated by  fred33 10 months, 2 weeks ago.

  • Creator
    Topic
  • #58156

    fred33
    Participant

    hi
    i’m on orocrm 2.04 and i have some problem on change user password. When i want to change a user password i have the message ‘impossible send email’
    Any idea ????

    Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • Author
    Replies
  • #58157
    msulima
    msulima
    Moderator

    Hi. Is the application configured correctly? Please, check parameters.yml in your application. Next parameters should be configured correctly.

    If all of they are correct. Please, attach log file with rows that added when you got error. It will help to understand you problem.


    #58158

    fred33
    Participant

    parameters are correct. What log file do u want ?

    #58159
    msulima
    msulima
    Moderator

    I told about app/logs/prod.log or app/logs/dev.log (depends on what environment you use).


    #58160

    fred33
    Participant

    Sorry, this a part of dev.log who insterested u i think

    #58162
    msulima
    msulima
    Moderator

    I see error in log

    It means that your smtp configuration not correct for your mail server.
    I hope that article can help http://stackoverflow.com/questions/31378357/laravel-5-sending-email


    #58163

    fred33
    Participant

    email configuration of user:
    SMTP HOST : smtp.gmail.com
    SMTP_PORT: 465
    SMTP_ENCRYPTION: SSL

    Same problem when i want to change user password when im login on admin profile

    #58164
    msulima
    msulima
    Moderator

    I think your problem described in article http://stackoverflow.com/questions/38816031/send-mail-from-localhost-via-symfony2-command-using-swiftmailer
    So, it seems you have 2-step authorization on gmail and you should generate password for you account to send emails via gmail smtp server.

    update: you should allow less secure apps in gmail settings https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting#gmail-oauth2-and-allow-less-secure-apps
    but you can’t do that if 2-step authorization is on


    #58165
    msulima
    msulima
    Moderator

    This is my settings and it works with ‘allow less secure apps’ settings


    #58166

    fred33
    Participant

    Hi,
    I’m the administrator of gmail account, 2-step authorization is disabled for all users, allow less secure apps is enabled for all user account cause without this option the recovery of email in OroCRM doesn’t work. Change password option works well in my OroCrm prod but it is in 1.10.12 version.

    #58167
    msulima
    msulima
    Moderator

    I checked twice and it works for me with my configuration and gmail account with ‘allow less secure apps’. Please, check telnet from your host to ssl and tls ports of smtp.gmail.com. I can’t connect via telnet to ssl port and it is why I use tls.


    #58168

    fred33
    Participant

    Right the 587 port was closed…. all works now. Thanks a lot for your help

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

ssossossosso