ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

Forums OroCRM OroCRM – Installation/Technical Issues or Problems Install fails on Centos 7.2.1511

This topic contains 24 replies, has 4 voices, and was last updated by Michael Michael 1 year, 11 months ago.

  • Creator
    Topic
  • #55830

    vfbsilva
    Participant

    Folks my installation fails with the following error:

    I have doubled checked my repositories and downloads, they should be oki.

    Composer is installed as you can see:

    I got it from https://getcomposer.org/download/ and I’m using version:
    1.0.0-alpha11 (2015-11-14)

    My machine has 2 GB RAM, is it enough? I’ve noticed that the machine almost runs into swap before failing at the installation. Ive read here https://github.com/composer/composer/issues/2704 and tried to install gaving the ram limit as a command line argument.

    Any pointers?

    Regards,
    vfbsilva

Viewing 15 replies - 1 through 15 (of 24 total)
  • Author
    Replies
  • #55831

    vfbsilva
    Participant

    So I answer my own question. I’ve foind that I needed a specific version of composer I’ve installed it modifying the composer.json to the following

    {
    “require”: {
    “oro/crm”: “^1.9”
    },
    “repositories”: [
    {
    “type”: “composer”,
    “url”: “http://packagist.orocrm.com”
    }
    ]

    }

    #55832

    vfbsilva
    Participant

    But now it fails with:

    But knp is installed on a newer version:

    #55833
    Ivan Klymenko
    Ivan Klymenko
    Keymaster

    Hi vfbsilva,
    we were not able to reproduce the issue described on the CentOS.
    Please clone latest stable OroCRM application from GitHub or use these composer.json and composer.lock and try again.

    #55834

    vfbsilva
    Participant

    I’ve tried with the composer files you provided and ended on the same error.

    #55835
    Ivan Klymenko
    Ivan Klymenko
    Keymaster

    Did you run “composer install” or “composer update”?
    Recommended way is to run composer install

    #55836

    vfbsilva
    Participant

    I’ve ran install as follows:

    #55837

    vfbsilva
    Participant

    I’ve fixed this issue by installing

    But now it fails with

    #55838

    vfbsilva
    Participant

    More details from the error here:

    #55839

    vfbsilva
    Participant

    So, I’ve discovered that running the install seems to must be made from inside the crm app folder. But now it fails again with no RAM despite the amount being defined on command line.

    #55840

    vfbsilva
    Participant

    I’ve edited the php.ini to have 12MB as default ram for php processes and now it is oki I finished the build but when I get to setup the database it fails:

    #55841

    vfbsilva
    Participant

    Okay I improved the situation but now the installer fails;Installation error

    #55842
    Ivan Klymenko
    Ivan Klymenko
    Keymaster

    Could you please share install and prod logs. We need to check the error to understand where could be an issue.

    #55843

    vfbsilva
    Participant

    Here we go.
    prod.log
    install.log

    #55844

    vfbsilva
    Participant

    I’ve cleared all the caches and got some progress. Not it fails with

    #55845

    vfbsilva
    Participant

    Cleared all buffers, dumped database started over same problem:

Viewing 15 replies - 1 through 15 (of 24 total)

You must be logged in to reply to this topic.

ssossossosso