ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

Forums OroCRM OroCRM – Installation/Technical Issues or Problems Problems with Installation on shared Hosting – Fatal Error CommandExecutor.php

This topic contains 3 replies, has 4 voices, and was last updated by  mon 1 year, 4 months ago.

  • Creator
    Topic
  • #56005

    gpixel
    Participant

    Hi,

    I am experiencing a problem with the oro crm installation on a shared hosting.
    After launching the web installer /web/install.php the System requirements check page shows that everything except the JS Engine is okay. If I continue with the installation I got the following fatal error:

    Fatal error: Uncaught exception ‘Symfony\Component\HttpFoundation\File\Exception\FileNotFoundException’ with message ‘The file “The PHP executable could not be found.” does not exist’ in /home/httpd/vhosts/gpixel.com/crm.gpixel.com/vendor/oro/platform/src/Oro/Bundle/InstallerBundle/CommandExecutor.php:322 Stack trace: #0 /home/httpd/vhosts/gpixel.com/crm.gpixel.com/vendor/oro/platform/src/Oro/Bundle/EntityExtendBundle/OroEntityExtendBundle.php(172): Oro\Bundle\InstallerBundle\CommandExecutor::getPhpExecutable() #1 /home/httpd/vhosts/gpixel.com/crm.gpixel.com/vendor/oro/platform/src/Oro/Bundle/EntityExtendBundle/OroEntityExtendBundle.php(97): Oro\Bundle\EntityExtendBundle\OroEntityExtendBundle->getPhpExecutable() #2 /home/httpd/vhosts/gpixel.com/crm.gpixel.com/vendor/oro/platform/src/Oro/Bundle/EntityExtendBundle/OroEntityExtendBundle.php(84): Oro\Bundle\EntityExtendBundle\OroEntityExtendBundle->checkConfigs() #3 /home/httpd/vhosts/gpixel.com/crm.gpixel.com/vendor/oro/platform/src/Oro/Bundle/EntityExtendBundle/OroEntityExt in /home/httpd/vhosts/gpixel.com/crm.gpixel.com/vendor/oro/platform/src/Oro/Bundle/InstallerBundle/CommandExecutor.php on line 322

    Any idea what the problem could be? Thanks for your support.

    Cheers

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #56006
    Alex Rudenko
    Alex Rudenko
    Moderator

    Hi Gpixel,

    Thank you for submitting your request. Please, make sure that you have installed PHP CLI and this one is into the system environment. Add some data about mentioned above questions and we will make every effort to respond to your request as soon as possible.

    Thank you,
    Alex

    #56007

    xargg
    Participant

    Hi,
    I’ve got the same problem and PHP CLI is installed. What can I do?
    thanks

    #56008

    mon
    Participant

    Same problem here with PHP CLI already installed… any help, please?

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

ssossossosso