Covering OroCRM topics, including community updates and company announcements.  Subscribe

Forums OroPlatform OroPlatform – Programming Questions Uncaught Error: Mismatched anonymous define() module

This topic contains 1 reply, has 1 voice, and was last updated by  archy_bold 1 year, 11 months ago.

  • Creator
  • #60538


    Hi there.

    I created a new action in my custom bundle to be used by the datagrid and added the following javascript to go with it:

    With a requirejs.yml that looks as follows:

    It works absolutely fine on my local machine but as soon as I deploy it to our server, we get the following error in the browser.

    This is preventing the CRM from being used. I’ve tried rebuilding the assets and it’s still broken. Is there something I’m missing here? I’ve read up on the problems and I tried naming my module, but that caused a different error. Any idea what’s going on?


Viewing 1 replies (of 1 total)
  • Author
  • #60539


    So the issue was a javascript issue as I was repeating a property in my object.

    This was really hard to trace as I was in dev mode on my machine and the live CRM was using a production environment. Even switching to production on the development machine didn’t work. The reason being that I wasn’t running the requirejs command:

    This command seems to be poorly documented and it took a random forum post to realise it exists. Could there not potentially be an oro:rebuild command that runs everything required to redeploy new code? And an explanation of what it does and in what order? I’ve had real difficulty working out what commands should be running each time I make a change to a bundle.

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.