Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

Forums OroPlatform OroPlatform – Installation/Technical Issues or Problems Installation on cPanel (lib-icu version 4.2)

This topic contains 5 replies, has 6 voices, and was last updated by  davidlin 2 years, 5 months ago.

  • Creator
    Topic
  • #1972

    bathcomms
    Participant

    I am trying to install OroCRM on a cPanel hosted site. The composer install fails as follows
    # php composer.phar install
    Loading composer repositories with package information
    Installing dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.

    Problem 1
    – Installation request for oro/platform 1.0.0-rc3 -> satisfiable by oro/platform[1.0.0-rc3].
    – oro/platform 1.0.0-rc3 requires lib-icu >=4.4 -> the requested linked library icu has the wrong version installed or is missing from y our system, make sure to have the extension providing it.
    Problem 2
    – oro/platform 1.0.0-rc3 requires lib-icu >=4.4 -> the requested linked library icu has the wrong version installed or is missing from y our system, make sure to have the extension providing it.
    – oro/crm-magento-embedded-contact-us 1.0.0-rc1 requires oro/platform 1.0.0-rc3 -> satisfiable by oro/platform[1.0.0-rc3].
    – Installation request for oro/crm-magento-embedded-contact-us 1.0.0-rc1 -> satisfiable by oro/crm-magento-embedded-contact-us[1.0.0-rc1 ].

    Is there a was to remove the dependancy on lib-icu >= 4.4

    Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #1973

    Alexandr Smaga
    Participant

    Hi.

    lib-icu is required for Oro so my suggestion is to install/update it on server.

    #1974
    Dima Soroka
    Dima Soroka
    Keymaster

    We are looking to remove dependency on lib-icu in next release or at list to reduce version requirements.

    #1975

    martyn.pearson
    Participant

    Hi,

    Are you able to explain how this issue can be worked around on Centos 6 / cPanel servers until the next release? I would really like to start testing our own install before the next release. Does that have an expected date by the way?

    Thanks,

    #1976
    Yevhen Shyshkin
    Yevhen Shyshkin
    Participant

    Hello, martyn.pearson.

    To lower libicu version you have to do following:

    1) set REQUIRED_ICU_VERSION = ‘3.8’ in OroRequirements.php (see https://github.com/orocrm/crm-application/blob/master/app/OroRequirements.php)
    2) remove libicu dependency from platform composer.json (i.e. remove string “lib-ICU”: “>=4.4” from https://github.com/orocrm/platform/blob/master/composer.json)
    3) lower version of symfony/icu to minimum 1.1 in composer.json (i.e. replace “symfony/icu”: “1.2.x-dev” with “symfony/icu”: “~1.1” in https://github.com/orocrm/platform/blob/master/composer.json)
    4) do “composer install” or “composer update” and check that will be downloaded symfony/icu version 1.1.1.

    All these fixes will be included in the next release.

    #1977

    davidlin
    Participant

    this problem is still there for the oro-crm version 1.9.0
    check https://github.com/orocrm/crm/issues/159

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No
ssossossossosso