Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

This topic contains 7 replies, has 3 voices, and was last updated by  andesk 3 years, 12 months ago.

  • Creator
    Topic
  • #2104

    andesk
    Participant

    Hi there again :)

    I just realized that OroPlatform has hardcoded dependency to symfony version 2.3.6 in composer.json. Current version of symfony 2.3.* is 2.3.18 including security fixes. Shouldn’t this dependency be updated? Are there any issues in those versions that stop oro from updating?

    Also most of other depending vendor libraries configured in composer.json even the patch version is fix in most cases. Will those be checked/updated on a more or less regular basis? We ran into the issues with knp-menu for example not that long ago…

    Greets,
    Andes

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
    Replies
  • #2105

    Alexandr Smaga
    Participant

    Hello.

    I’ve already configured our builds to check if they are green with 2.3.18 :)
    Hope we will migrate to it till next release.

    #2106

    andesk
    Participant

    Hmmm, did not make it into Oro 1.3.0. So no green lights here? ;)

    #2107
    Dima Soroka
    Dima Soroka
    Keymaster

    This update will be included into 1.3.1 which is coming soon.

    #2108

    andesk
    Participant

    Ah ok. Thanks for the quick response :)

    #2109

    andesk
    Participant

    Looks like “2.3.6” could be successfully changed to “2.3.*” in oro 1.3.1 :)

    #2110

    Alexandr Smaga
    Participant

    Hello!

    1.3.1 is already has "symfony/symfony": "2.3.*"

    #2111

    andesk
    Participant

    That’s what I wanted to point out, just for completeness of the topic ;)

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No
ssossossossosso