ssossossosso

Forums

Covering OroCRM topics, including community updates and company announcements.  Subscribe

Forums OroCRM Migration error: Property does not exists

This topic contains 5 replies, has 3 voices, and was last updated by Mike Kudelya Mike Kudelya 1 year, 2 months ago.

  • Creator
    Topic
  • #59364
    Sufiyan Malek
    Sufiyan Malek
    Participant

    Hi,

    I have added migration code for field “industry” which is relational as below.

    I got following error

    when I run php app/console oro:migration:load --force --show-queries command.

    And to resolve this, I executed php app/console oro:entity-extend:update-schema command 2 time than error went.

    But when next time I add some new fields in migration than again it throws same error for industry and new field not added in extended entity. Due to this I am not able to use new fields in form.

    Thankx

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #59365

    jderdziak
    Participant

    Hello,

    Can you also provide Migration that creates dataindustry table and Entity class for it?

    Also, can you try to do this migration to some other OroCRM table, ie:

    Finally, when you run

    command, is this error the only thing that shows, or you can see queries? If yes, can you copy here the query that creates this migration?

    #59367
    Sufiyan Malek
    Sufiyan Malek
    Participant

    Hi,
    Thank you for quick response.

    I have used

    in other table “orocrm_sales_lead” too, and it’s working fine there.

    when I created new field after creating industry migration following result occurs.

    and my industry entity is:

    and oro:entity-extend:cache:clear command gives same error result.

    and one more thing is, if I remove industry field than my next relation field in account “country” gives same error result for country field.

    Thankx

    #59369
    Mike Kudelya
    Mike Kudelya
    Moderator

    Hi

    Do you use the OPCache php extension? If yes, try to disable it during install or update.
    Usually i use the “app/console oro:platform:update –env=prod –force” command when migration has been added.


    #59370
    Sufiyan Malek
    Sufiyan Malek
    Participant

    Hi,
    Mike Kudelya.

    You saved my life.
    But error still shows when I use cache clear command in dev environment, not in production.

    So, should not use php app/console oro:migration:load --force --show-queries anymore ?

    Thankx

    #59372
    Mike Kudelya
    Mike Kudelya
    Moderator

    Hi

    Please, delete our /app/cache/dev&prod folders and try to run “app/console oro:platform:update –env=prod –force” again. In any case, the ‘app/cache/[prod or dev]/oro_entities/Extend/Entity/EX_OroAccountBundle_Account.php’ file must contain the $industry property.


Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

You will be redirected to [title]. Would you like to continue?

Yes No
ssossossosso